wiki:centos:neue_php-versionen

neue PHP-Versionen in Centos7

CentOS7 wird standardmäßig mit PHP v5.4 ausgeliefert. Dies ist laut Webseite kein Bug, sondern ein Sicherheitsfeature
Es wurde bewusst auf das viel zitierte webtatic-Repo verzichtet, da es auch von Offizieller Seite (https://wiki.centos.org/AdditionalResources/Repositories) nicht wirklich supportet ist und zu Problemen führen kann

Abhilfe schafft man mit dieser Anleitung:

yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm

über yum list-repo all kann man nun alle verfügbaren Repositories anzeigen lassen
Für PHP v5.6 ist das Repo remi-php56 zuständig. Dieses muss nun aktiviert werden.

Entweder man geht in die entsprechende Repo-Datei (unter /etc/yum.repos.d/remi.repo) oder man aktiviert elegant (yum-utils muss installiert sein) das Paket über:

yum-config-manager --enable remi-php56

Ein yum update aktualisiert die Repositories und die Pakete. Es werden autmatisch alle PHP v5.4 Pakete auf die gewünschten PHP Versionen upgedatet.

Quellen

Geben Sie Ihren Kommentar ein. Wiki-Syntax ist zugelassen:
  _      __   ___    _  __  _____ ______
 | | /| / /  / _ )  / |/ / / ___//_  __/
 | |/ |/ /  / _  | /    / / /__   / /   
 |__/|__/  /____/ /_/|_/  \___/  /_/
 
  • wiki/centos/neue_php-versionen.txt
  • Zuletzt geändert: 2017/03/02 16:01
  • von wikiadmin